import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9_-]+$";
final String string = "gamertag\n"
+ "GamerTag\n"
+ "Gamer_Tag\n"
+ "_GamerTag\n"
+ "GamerTag_-\n"
+ "GamerTag\n"
+ "Gamer-Tag\n"
+ "GamerTag-\n\n"
+ "!GamerTag\n"
+ "Gamer%Tag\n"
+ "Gamer Tag";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}