#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[a-z0-9.\-\s]"
Local $sString = "𝙍𝙖𝙣𝙙𝙧𝙞𝙖𝙣𝙟𝙖𝙛𝙞𝙢𝙖𝙝𝙖𝙩𝙧𝙖𝙩𝙧𝙖" & @CRLF & _
"Ra.ndri anjafi. mahtr-atra1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")