re = /[a-z0-9.\-\s]/mi
str = '𝙍𝙖𝙣𝙙𝙧𝙞𝙖𝙣𝙟𝙖𝙛𝙞𝙢𝙖𝙝𝙖𝙩𝙧𝙖𝙩𝙧𝙖
Ra.ndri anjafi. mahtr-atra1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end