using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z0-9.\-\s]";
string input = @"𝙍𝙖𝙣𝙙𝙧𝙞𝙖𝙣𝙟𝙖𝙛𝙞𝙢𝙖𝙝𝙖𝙩𝙧𝙖𝙩𝙧𝙖
Ra.ndri anjafi. mahtr-atra1";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}