import re
regex = re.compile(r"[a-z0-9.\-\s]", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("𝙍𝙖𝙣𝙙𝙧𝙞𝙖𝙣𝙟𝙖𝙛𝙞𝙢𝙖𝙝𝙖𝙩𝙧𝙖𝙩𝙧𝙖\n"
"Ra.ndri anjafi. mahtr-atra1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")