package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[a-z0-9.\-\s]`)
var str = `𝙍𝙖𝙣𝙙𝙧𝙞𝙖𝙣𝙟𝙖𝙛𝙞𝙢𝙖𝙝𝙖𝙩𝙧𝙖𝙩𝙧𝙖
Ra.ndri anjafi. mahtr-atra1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}