import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s](\\d{1,})(\\s+)(\\w\\W\\W.+)";
final String string = " 72880735 H:\\1.txt\n"
+ "100% \n"
+ " 33038490 H:\\10.txt\n"
+ "100% \n"
+ " 64878348 H:\\2.txt\n"
+ "100% \n"
+ " 25875810 H:\\3.txt\n"
+ " 0% \n"
+ "100% ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}