$re = '/[\s](\d{1,})(\s+)(\w\W\W.+)/';
$str = ' 72880735 H:\\1.txt
100%
33038490 H:\\10.txt
100%
64878348 H:\\2.txt
100%
25875810 H:\\3.txt
0%
100% ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);