// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\s](\d{1,})(\s+)(\w\W\W.+)").unwrap();
let string = " 72880735 H:\\1.txt
100%
33038490 H:\\10.txt
100%
64878348 H:\\2.txt
100%
25875810 H:\\3.txt
0%
100% ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}