const regex = /[\s](\d{1,})(\s+)(\w\W\W.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s](\\d{1,})(\\s+)(\\w\\W\\W.+)', 'g')
const str = ` 72880735 H:\\1.txt
100%
33038490 H:\\10.txt
100%
64878348 H:\\2.txt
100%
25875810 H:\\3.txt
0%
100% `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}