use strict;
my $str = ' 72880735 H:\\1.txt
100%
33038490 H:\\10.txt
100%
64878348 H:\\2.txt
100%
25875810 H:\\3.txt
0%
100% ';
my $regex = qr/[\s](\d{1,})(\s+)(\w\W\W.+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}