using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"##IF (.*?)##(.*?)(?:##ELSE##(.*?))?##ENDIF##";
string input = @"##IF x()## foo ##ELSE## bar ##ENDIF##
##IF y()## foo ##ENDIF##
##IF g()## pre-outer-if ##IF h()## inner-if ##ENDIF## post-outer-if ##ELSE## outer-else ##ENDIF##";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}