re = /##IF (.*?)##(.*?)(?:##ELSE##(.*?))?##ENDIF##/m
str = '##IF x()## foo ##ELSE## bar ##ENDIF##
##IF y()## foo ##ENDIF##
##IF g()## pre-outer-if ##IF h()## inner-if ##ENDIF## post-outer-if ##ELSE## outer-else ##ENDIF##'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end