package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)##IF (.*?)##(.*?)(?:##ELSE##(.*?))?##ENDIF##`)
var str = `##IF x()## foo ##ELSE## bar ##ENDIF##
##IF y()## foo ##ENDIF##
##IF g()## pre-outer-if ##IF h()## inner-if ##ENDIF## post-outer-if ##ELSE## outer-else ##ENDIF##`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}