// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sm)##IF (.*?)##(.*?)(?:##ELSE##(.*?))?##ENDIF##").unwrap();
let string = "##IF x()## foo ##ELSE## bar ##ENDIF##
##IF y()## foo ##ENDIF##
##IF g()## pre-outer-if ##IF h()## inner-if ##ENDIF## post-outer-if ##ELSE## outer-else ##ENDIF##";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}