$re = '/##IF (.*?)##(.*?)(?:##ELSE##(.*?))?##ENDIF##/sm';
$str = '##IF x()## foo ##ELSE## bar ##ENDIF##
##IF y()## foo ##ENDIF##
##IF g()## pre-outer-if ##IF h()## inner-if ##ENDIF## post-outer-if ##ELSE## outer-else ##ENDIF##';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);