#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[%]?([B])(.+?(?=\^))[\^](.+?(?=\^))[\^](\d\d)(\d\d)(\d)(\d)(\d)(.*)$"
Local $sString = "%B5117810649516789^VINICIUS/M R SILVA ^23082261000000000000000000000503000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")