import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[%]?([B])(.+?(?=\\^))[\\^](.+?(?=\\^))[\\^](\\d\\d)(\\d\\d)(\\d)(\\d)(\\d)(.*)$";
final String string = "%B5117810649516789^VINICIUS/M R SILVA ^23082261000000000000000000000503000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}