re = /^[%]?([B])(.+?(?=\^))[\^](.+?(?=\^))[\^](\d\d)(\d\d)(\d)(\d)(\d)(.*)$/m
str = '%B5117810649516789^VINICIUS/M R SILVA ^23082261000000000000000000000503000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end