$re = '/^[%]?([B])(.+?(?=\^))[\^](.+?(?=\^))[\^](\d\d)(\d\d)(\d)(\d)(\d)(.*)$/m';
$str = '%B5117810649516789^VINICIUS/M R SILVA ^23082261000000000000000000000503000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);