using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[%]?([B])(.+?(?=\^))[\^](.+?(?=\^))[\^](\d\d)(\d\d)(\d)(\d)(\d)(.*)$";
string input = @"%B5117810649516789^VINICIUS/M R SILVA ^23082261000000000000000000000503000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}