import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)(?:\\d*\\.)?\\d+";
final String string = ".1875 X 7.00 X 8.800 \n"
+ "7.00 X .1875 X 8.800 \n"
+ ".50\" x 1.25\" x 7.125\" will make one part\n\n"
+ ".1875 X 7.00 X 8.800 X 456 X 13.45.56.343.343.\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}