import re
regex = re.compile(r"(?<!\d)(?:\d*\.)?\d+")
test_str = (".1875 X 7.00 X 8.800 \n"
"7.00 X .1875 X 8.800 \n"
".50\" x 1.25\" x 7.125\" will make one part\n\n"
".1875 X 7.00 X 8.800 X 456 X 13.45.56.343.343.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")