re = /(?<!\d)(?:\d*\.)?\d+/
str = '.1875 X 7.00 X 8.800
7.00 X .1875 X 8.800
.50" x 1.25" x 7.125" will make one part
.1875 X 7.00 X 8.800 X 456 X 13.45.56.343.343.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end