#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^:;\n]*)(:\d+)?;([^;\n]*)(;.*\b\3\b=|;.*;|;)(\d+)(,.*|;)?$"
Local $sString = "# with k/v pairs declared" & @CRLF & _
"app.default.svc.local;http-metrics;http-metrics=9090;" & @CRLF & _
"app.default.svc.local;http-metrics;;http-metrics=9090" & @CRLF & _
"app.default.svc.local;http-metrics;http-server=9090;" & @CRLF & _
"app.default.svc.local:8000;http-metrics;http-metrics=9090;" & @CRLF & _
"app.default.svc.local:8000;http-metrics;;http-metrics=9090 " & @CRLF & _
"app.default.svc.local:8000;http-metrics;http-server=9090;" & @CRLF & _
"app.default.svc.local;http-metrics;http-metrics=9090,http-server=8000;" & @CRLF & _
"app.default.svc.local;http-metrics;;http-metrics=9090,http-server=8000" & @CRLF & _
"app.default.svc.local;http-metrics;http-server=9090,http-server=8000;" & @CRLF & _
"app.default.svc.local:8000;http-metrics;http-metrics=9090,http-server=8000;" & @CRLF & _
"app.default.svc.local:8000;http-metrics;;http-metrics=9090,http-server=8000" & @CRLF & _
"app.default.svc.local:8000;http-metrics;http-server=9090;" & @CRLF & _
"" & @CRLF & _
"app.default.svc.local;http-server;http-metrics=9090,http-server=8000;" & @CRLF & _
"app.default.svc.local;http-server;;http-metrics=9090,http-server=8000" & @CRLF & _
"app.default.svc.local;http-server;http-metrics=9090,http-server=8000;" & @CRLF & _
"app.default.svc.local:8000;http-server;http-metrics=9090,http-server=8000;" & @CRLF & _
"app.default.svc.local:8000;http-server;;http-metrics=9090,http-server=8000" & @CRLF & _
"app.default.svc.local:8000;http-server;http-metrics=9090;" & @CRLF & _
"" & @CRLF & _
"# without k/v pairs " & @CRLF & _
"app.default.svc.local;http-metrics;9090;" & @CRLF & _
"app.default.svc.local;http-metrics;;9090" & @CRLF & _
"app.default.svc.local;http-metrics;http-server=9090;" & @CRLF & _
"app.default.svc.local:8000;http-metrics;9090;" & @CRLF & _
"app.default.svc.local:8000;http-metrics;;9090" & @CRLF & _
"app.default.svc.local:8000;http-metrics;http-server=9090;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")