use strict;
my $str = '# with k/v pairs declared
app.default.svc.local;http-metrics;http-metrics=9090;
app.default.svc.local;http-metrics;;http-metrics=9090
app.default.svc.local;http-metrics;http-server=9090;
app.default.svc.local:8000;http-metrics;http-metrics=9090;
app.default.svc.local:8000;http-metrics;;http-metrics=9090
app.default.svc.local:8000;http-metrics;http-server=9090;
app.default.svc.local;http-metrics;http-metrics=9090,http-server=8000;
app.default.svc.local;http-metrics;;http-metrics=9090,http-server=8000
app.default.svc.local;http-metrics;http-server=9090,http-server=8000;
app.default.svc.local:8000;http-metrics;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-metrics;;http-metrics=9090,http-server=8000
app.default.svc.local:8000;http-metrics;http-server=9090;
app.default.svc.local;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local;http-server;;http-metrics=9090,http-server=8000
app.default.svc.local;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-server;;http-metrics=9090,http-server=8000
app.default.svc.local:8000;http-server;http-metrics=9090;
# without k/v pairs
app.default.svc.local;http-metrics;9090;
app.default.svc.local;http-metrics;;9090
app.default.svc.local;http-metrics;http-server=9090;
app.default.svc.local:8000;http-metrics;9090;
app.default.svc.local:8000;http-metrics;;9090
app.default.svc.local:8000;http-metrics;http-server=9090;';
my $regex = qr/^([^:;\n]*)(:\d+)?;([^;\n]*)(;.*\b\3\b=|;.*;|;)(\d+)(,.*|;)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}