import re
regex = re.compile(r"^([^:;\n]*)(:\d+)?;([^;\n]*)(;.*\b\3\b=|;.*;|;)(\d+)(,.*|;)?$", flags=re.MULTILINE)
test_str = ("# with k/v pairs declared\n"
"app.default.svc.local;http-metrics;http-metrics=9090;\n"
"app.default.svc.local;http-metrics;;http-metrics=9090\n"
"app.default.svc.local;http-metrics;http-server=9090;\n"
"app.default.svc.local:8000;http-metrics;http-metrics=9090;\n"
"app.default.svc.local:8000;http-metrics;;http-metrics=9090 \n"
"app.default.svc.local:8000;http-metrics;http-server=9090;\n"
"app.default.svc.local;http-metrics;http-metrics=9090,http-server=8000;\n"
"app.default.svc.local;http-metrics;;http-metrics=9090,http-server=8000\n"
"app.default.svc.local;http-metrics;http-server=9090,http-server=8000;\n"
"app.default.svc.local:8000;http-metrics;http-metrics=9090,http-server=8000;\n"
"app.default.svc.local:8000;http-metrics;;http-metrics=9090,http-server=8000\n"
"app.default.svc.local:8000;http-metrics;http-server=9090;\n\n"
"app.default.svc.local;http-server;http-metrics=9090,http-server=8000;\n"
"app.default.svc.local;http-server;;http-metrics=9090,http-server=8000\n"
"app.default.svc.local;http-server;http-metrics=9090,http-server=8000;\n"
"app.default.svc.local:8000;http-server;http-metrics=9090,http-server=8000;\n"
"app.default.svc.local:8000;http-server;;http-metrics=9090,http-server=8000\n"
"app.default.svc.local:8000;http-server;http-metrics=9090;\n\n"
"# without k/v pairs \n"
"app.default.svc.local;http-metrics;9090;\n"
"app.default.svc.local;http-metrics;;9090\n"
"app.default.svc.local;http-metrics;http-server=9090;\n"
"app.default.svc.local:8000;http-metrics;9090;\n"
"app.default.svc.local:8000;http-metrics;;9090\n"
"app.default.svc.local:8000;http-metrics;http-server=9090;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")