re = /^([^:;\n]*)(:\d+)?;([^;\n]*)(;.*\b\3\b=|;.*;|;)(\d+)(,.*|;)?$/m
str = '# with k/v pairs declared
app.default.svc.local;http-metrics;http-metrics=9090;
app.default.svc.local;http-metrics;;http-metrics=9090
app.default.svc.local;http-metrics;http-server=9090;
app.default.svc.local:8000;http-metrics;http-metrics=9090;
app.default.svc.local:8000;http-metrics;;http-metrics=9090
app.default.svc.local:8000;http-metrics;http-server=9090;
app.default.svc.local;http-metrics;http-metrics=9090,http-server=8000;
app.default.svc.local;http-metrics;;http-metrics=9090,http-server=8000
app.default.svc.local;http-metrics;http-server=9090,http-server=8000;
app.default.svc.local:8000;http-metrics;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-metrics;;http-metrics=9090,http-server=8000
app.default.svc.local:8000;http-metrics;http-server=9090;
app.default.svc.local;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local;http-server;;http-metrics=9090,http-server=8000
app.default.svc.local;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-server;http-metrics=9090,http-server=8000;
app.default.svc.local:8000;http-server;;http-metrics=9090,http-server=8000
app.default.svc.local:8000;http-server;http-metrics=9090;
# without k/v pairs
app.default.svc.local;http-metrics;9090;
app.default.svc.local;http-metrics;;9090
app.default.svc.local;http-metrics;http-server=9090;
app.default.svc.local:8000;http-metrics;9090;
app.default.svc.local:8000;http-metrics;;9090
app.default.svc.local:8000;http-metrics;http-server=9090;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end