#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?|"([^"\n]*)"|'([^'\n]*)')"
Local $sString = "My text "can contain" both single 'and double"' quotes. The quotes "can also be 'nested" as you can see." & @CRLF & _
"Valid / invalid" & @CRLF & _
"Valid: This is "A text" (A text)" & @CRLF & _
"Valid: This is 'A text' (A text)" & @CRLF & _
"Valid: This is "A 'text" (A ]text)" & @CRLF & _
"Valid: This is 'A "text' (A [text)" & @CRLF & _
"Invalid: This is "A text (Uneven quotes 1)" & @CRLF & _
"Invalid: This is 'A text (Uneven quotes 1)" & @CRLF & _
"Invalid: This is "A "text" (Uneven quotes 3)" & @CRLF & _
"Invalid: This is 'A 'text'(Uneven quotes 3)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")