package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|"([^"\n]*)"|'([^'\n]*)')`)
var str = `My text "can contain" both single 'and double"' quotes. The quotes "can also be 'nested" as you can see.
Valid / invalid
Valid: This is "A text" (A text)
Valid: This is 'A text' (A text)
Valid: This is "A 'text" (A ]text)
Valid: This is 'A "text' (A [text)
Invalid: This is "A text (Uneven quotes 1)
Invalid: This is 'A text (Uneven quotes 1)
Invalid: This is "A "text" (Uneven quotes 3)
Invalid: This is 'A 'text'(Uneven quotes 3)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}