re = /(?|"([^"\n]*)"|'([^'\n]*)')/m
str = 'My text "can contain" both single \'and double"\' quotes. The quotes "can also be \'nested" as you can see.
Valid / invalid
Valid: This is "A text" (A text)
Valid: This is \'A text\' (A text)
Valid: This is "A \'text" (A ]text)
Valid: This is \'A "text\' (A [text)
Invalid: This is "A text (Uneven quotes 1)
Invalid: This is \'A text (Uneven quotes 1)
Invalid: This is "A "text" (Uneven quotes 3)
Invalid: This is \'A \'text\'(Uneven quotes 3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end