const regex = /(?|"([^"\n]*)"|'([^'\n]*)')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|"([^"\\n]*)"|\'([^\'\\n]*)\')', 'gm')
const str = `My text "can contain" both single 'and double"' quotes. The quotes "can also be 'nested" as you can see.
Valid / invalid
Valid: This is "A text" (A text)
Valid: This is 'A text' (A text)
Valid: This is "A 'text" (A ]text)
Valid: This is 'A "text' (A [text)
Invalid: This is "A text (Uneven quotes 1)
Invalid: This is 'A text (Uneven quotes 1)
Invalid: This is "A "text" (Uneven quotes 3)
Invalid: This is 'A 'text'(Uneven quotes 3)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}