// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?|"([^"\n]*)"|'([^'\n]*)')"#).unwrap();
let string = "My text \"can contain\" both single 'and double\"' quotes. The quotes \"can also be 'nested\" as you can see.
Valid / invalid
Valid: This is \"A text\" (A text)
Valid: This is 'A text' (A text)
Valid: This is \"A 'text\" (A ]text)
Valid: This is 'A \"text' (A [text)
Invalid: This is \"A text (Uneven quotes 1)
Invalid: This is 'A text (Uneven quotes 1)
Invalid: This is \"A \"text\" (Uneven quotes 3)
Invalid: This is 'A 'text'(Uneven quotes 3)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}