using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|""([^\n""\\]*(?:\\.[^\n""\\]*)*)""|'([^\n'\\]*(?:\\.[^\n'\\]*)*)')";
string input = @"My text ""can contain"" both single 'and double""' quotes. The quotes ""can also be 'nested"" as you can see.
Valid / invalid
Valid: This is ""A text"" (A text)
Valid: This is 'A text' (A text)
Valid: This is ""A 'text"" (A ]text)
Valid: This is 'A ""text' (A [text)
Invalid: This is ""A text (Uneven quotes 1)
Invalid: This is 'A text (Uneven quotes 1)
Invalid: This is ""A ""text"" (Uneven quotes 3)
Invalid: This is 'A 'text'(Uneven quotes 3)
My text ""can \""contain\"" both single 'and \'double\'""' quotes. The quotes ""can also be\"" \' 'nested"" as you can see.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}