import Foundation
let pattern = #"(?|"([^\n"\\]*(?:\\.[^\n"\\]*)*)"|'([^\n'\\]*(?:\\.[^\n'\\]*)*)')"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
My text "can contain" both single 'and double"' quotes. The quotes "can also be 'nested" as you can see.
Valid / invalid
Valid: This is "A text" (A text)
Valid: This is 'A text' (A text)
Valid: This is "A 'text" (A ]text)
Valid: This is 'A "text' (A [text)
Invalid: This is "A text (Uneven quotes 1)
Invalid: This is 'A text (Uneven quotes 1)
Invalid: This is "A "text" (Uneven quotes 3)
Invalid: This is 'A 'text'(Uneven quotes 3)
My text "can \"contain\"" both single 'and \'double\'"' quotes. The quotes "can also be\" \' 'nested" as you can see.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)