$re = '/(?|"([^\n"\\\\]*(?:\\\\.[^\n"\\\\]*)*)"|\'([^\n\'\\\\]*(?:\\\\.[^\n\'\\\\]*)*)\')/s';
$str = 'My text "can contain" both single \'and double"\' quotes. The quotes "can also be \'nested" as you can see.
Valid / invalid
Valid: This is "A text" (A text)
Valid: This is \'A text\' (A text)
Valid: This is "A \'text" (A ]text)
Valid: This is \'A "text\' (A [text)
Invalid: This is "A text (Uneven quotes 1)
Invalid: This is \'A text (Uneven quotes 1)
Invalid: This is "A "text" (Uneven quotes 3)
Invalid: This is \'A \'text\'(Uneven quotes 3)
My text "can \\"contain\\"" both single \'and \\\'double\\\'"\' quotes. The quotes "can also be\\" \\\' \'nested" as you can see.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);