use strict;
my $str = 'My text "can contain" both single \'and double"\' quotes. The quotes "can also be \'nested" as you can see.
Valid / invalid
Valid: This is "A text" (A text)
Valid: This is \'A text\' (A text)
Valid: This is "A \'text" (A ]text)
Valid: This is \'A "text\' (A [text)
Invalid: This is "A text (Uneven quotes 1)
Invalid: This is \'A text (Uneven quotes 1)
Invalid: This is "A "text" (Uneven quotes 3)
Invalid: This is \'A \'text\'(Uneven quotes 3)
My text "can \\"contain\\"" both single \'and \\\'double\\\'"\' quotes. The quotes "can also be\\" \\\' \'nested" as you can see.';
my $regex = qr/(?|"([^\n"\\]*(?:\\.[^\n"\\]*)*)"|'([^\n'\\]*(?:\\.[^\n'\\]*)*)')/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}