import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|\"([^\\n\"\\\\]*(?:\\\\.[^\\n\"\\\\]*)*)\"|'([^\\n'\\\\]*(?:\\\\.[^\\n'\\\\]*)*)')";
final String string = "My text \"can contain\" both single 'and double\"' quotes. The quotes \"can also be 'nested\" as you can see.\n"
+ "Valid / invalid\n"
+ "Valid: This is \"A text\" (A text)\n"
+ "Valid: This is 'A text' (A text)\n"
+ "Valid: This is \"A 'text\" (A ]text)\n"
+ "Valid: This is 'A \"text' (A [text)\n"
+ "Invalid: This is \"A text (Uneven quotes 1)\n"
+ "Invalid: This is 'A text (Uneven quotes 1)\n"
+ "Invalid: This is \"A \"text\" (Uneven quotes 3)\n"
+ "Invalid: This is 'A 'text'(Uneven quotes 3)\n\n"
+ "My text \"can \\\"contain\\\"\" both single 'and \\'double\\'\"' quotes. The quotes \"can also be\\\" \\' 'nested\" as you can see.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}