# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[[^[\]\n]*\])|!/$1/gm;t' <<< "[some tex!t !]
[som!e text !
!some text !
] ! foobar"