const regex = /(\[[^[\]\n]*\])|!/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[[^[\\]\\n]*\\])|!', 'gm')
const str = `[some tex!t !]
[som!e text !
!some text !
] ! foobar`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);