re = /(\[[^[\]\n]*\])|!/m
str = '[some tex!t !]
[som!e text !
!some text !
] ! foobar'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result