#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[[^[\]\n]*\])|!"
Local $sString = "[some tex!t !]" & @CRLF & _
"[som!e text !" & @CRLF & _
"!some text !" & @CRLF & _
"] ! foobar"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)