package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[[^[\]\n]*\])|!`)
var str = `[some tex!t !]
[som!e text !
!some text !
] ! foobar`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}