using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"baseline for+(100|[1-9][0-9]?)?\.png";
string input = @"b0000.png
b0001.png
b0099.png
b0100.png
b0101.png
b0373.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}