import re
regex = re.compile(r"baseline for+(100|[1-9][0-9]?)?\.png", flags=re.MULTILINE)
test_str = ("b0000.png\n"
"b0001.png\n"
"b0099.png\n"
"b0100.png\n\n"
"b0101.png\n"
"b0373.png")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")