import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "baseline for+(100|[1-9][0-9]?)?\\.png";
final String string = "b0000.png\n"
+ "b0001.png\n"
+ "b0099.png\n"
+ "b0100.png\n\n"
+ "b0101.png\n"
+ "b0373.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}