const regex = /baseline for+(100|[1-9][0-9]?)?\.png/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('baseline for+(100|[1-9][0-9]?)?\\.png', 'gm')
const str = `b0000.png
b0001.png
b0099.png
b0100.png
b0101.png
b0373.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}