re = /baseline for+(100|[1-9][0-9]?)?\.png/m
str = 'b0000.png
b0001.png
b0099.png
b0100.png
b0101.png
b0373.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end