#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"Sales_Rep_lookup__c":("?)(?<Salerep>.*?)("?)*?,"Opportunity__c":("?)(?<Opptun>.*?)("?)*?,"Project__c":("?)(?<project>.*?)("?)}]}"
Local $sString = "{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v43.0/sobjects/Contact/0031K00002q8BrXQAU"},"Id":"0031K00002q8BrXQAU","Phone":"7032847786","Sales_Rep_lookup__c":"a1J1K00000NLykQUAT","Opportunity__c":"0061K00000eQXdIQAW","Project__c":"a0h1K00000CQzHpQAL"}]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")