// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"Sales_Rep_lookup__c":("?)(?<Salerep>.*?)("?)*?,"Opportunity__c":("?)(?<Opptun>.*?)("?)*?,"Project__c":("?)(?<project>.*?)("?)}]}"#).unwrap();
let string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v43.0/sobjects/Contact/0031K00002q8BrXQAU\"},\"Id\":\"0031K00002q8BrXQAU\",\"Phone\":\"7032847786\",\"Sales_Rep_lookup__c\":\"a1J1K00000NLykQUAT\",\"Opportunity__c\":\"0061K00000eQXdIQAW\",\"Project__c\":\"a0h1K00000CQzHpQAL\"}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}